Willkommen Gast. Bitte anmelden oder registrieren.

Autor Thema: Total Offtopic ;-) : Joomla 1.0.x / php 5.3  (Gelesen 1830 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Sammy

  • Bestätigter Nutzer
  • Beiträge: 165
Total Offtopic ;-) : Joomla 1.0.x / php 5.3
« am: 23. Dezember 2012, 10:11:03 »
Hallo,

ich möchte keine lange Diskussion über Sinn und Unsinn von Updates beginnen, weil wir da sowieso der selben Meinung sind.
Tatsache ist aber leider, dass ich für meine Mannschaft, deren bestehen über diese Saison hinaus sehr fraglich ist, ein quasi nur internes Portal unter Joomla 1.0.x (die letzte) betreibe (quasi nur der Core). Ich habe dafür eine umfangreiche Erweiterung geschrieben, die nicht mal eben neu geschrieben ist und meine Versuche damit zu beginnen endeten vor wenigen Monaten wegen Zeitmangels habe sich aus gesundheitlichen Gründen auch erledigt. Nun läuft aber (was ich etwas verschlampt habe) der Einsatz von PHP 5.2 bei meinem Provider aus, so dass ich nicht nach der sicheren sondern (da bin ich mit J1.0 eh Jahre zu spät) schnellen Lösung suche.
Man findet diverse Tipps, was man machen kann um bsw. den Content wieder angezeigt zu bekommen, außerdem bin ich über ein Github-Projetk gestolpert:
https://github.com/micheas/Joomla-1.0

Hat jmd. vielleicht mit einer solchen Aktion Erfahrung und kann 'die eine' Anleitung empfehlen?
Wie gesagt, absolut keine Möglichkeit der Umstellung und rein internes Projekt und ich weiß, dass die Seite schon lange veraltet ist.

Sammy

  • Bestätigter Nutzer
  • Beiträge: 165
Antw: Total Offtopic ;-) : Joomla 1.0.x / php 5.3
« Antwort #1 am: 28. Dezember 2012, 13:10:58 »
Ooops, meine 'Doppelpost'-Angabe ist gar nicht hier angekommen, war von unterwegs mit dem Handy...
Ich habe auch hier noch einmal nachgefragt, weil die Zeit etwas drängelte. Da dort bereits eine Antwort kam, alles weitere dort.
http://www.joomlaportal.de/off-topic/289022-total-offtopic-joomla-1-0-x-php-5-3-a.html

addi

  • Bestätigter Nutzer
  • Beiträge: 26
Antw: Total Offtopic ;-) : Joomla 1.0.x / php 5.3
« Antwort #2 am: 17. Januar 2013, 12:58:13 »
Du müsstest einfach die wenigen Stellen, die bei 5.3 nicht mehr funktionieren - da deprecated - austauschen. Dazu muss man nicht mal programmieren können, sondern einfach nur die Fehler erzeugenden Codestellen patchen und vorher am besten das Problem verstanden haben.

mrairbrush

  • Unter Beobachtung
  • Beiträge: 1
Antw: Total Offtopic ;-) : Joomla 1.0.x / php 5.3
« Antwort #3 am: 03. Mai 2015, 15:51:49 »
Es gibt die Möglichkeit eine weitere PHP auf dem Server version zu installieren mit dem einzelne Domains laufen und die kompatibel mit einem alten Joomla sind. Ist einfacher als eine gganze alte Joomlaversion anzupassen. Dazu müßte man erst alle nicht mehr verwendeten oder geänderten Befehle im Source ändern. Viel zu aufwändig. Ich habe für eine alte Version noch eine php 4.3 auf meinem Server laufen.
Thema ist zwar älter aber in den Sumas landet es trotzdem.