Willkommen Gast. Bitte anmelden oder registrieren.

Autor Thema: Meta Tag für Robots; Bug oder nicht Bug?  (Gelesen 2263 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Joomla-Hilfe

  • Oberwetterfrosch (Mod)
  • Beiträge: 155
Meta Tag für Robots; Bug oder nicht Bug?
« am: 22. März 2012, 19:39:09 »
http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_item_id=28289

Seit 1.6 kann das Meta Tag für Robots direkt im Menüpunkt gesetzt werden. Seit 2.5 fällt es wieder weg, wenn die Default-Einstellung "index,follow" gesetzt ist. Sobald eine andere gesetzt ist, erscheint es, aber nur bei den Joomla-internen Komponenten, soweit ich das bis jetzt sehe. Bei JoomPJIRC, Phocagallery und Phocamaps erscheint es nicht, auch wenn im Menü für die Seite "noindex,nofollow" eingestellt wird.

Damit ist leider mein Kontingent an schnell verfügbaren Testobjekten erschöpft. Kann jemand das mit weiteren nachinstallierten Komponenten testen?

Rouven Weßling (realityking) hält das offensichtlich für einen Bug in den Komponenten. In der Doku finde ich aber nicht den kleinsten Hinweis, daß eine Komponente den Parameter selbst abfragen und das Tag entsprechend setzen müßte. Ist das nun ein Bug in Joomla oder in den Komponenten?
Dietmar

Die Realität ist eine Halluzination, die durch akuten Alkoholmangel hervorgerufen wird.

Hackwar

  • Bestätigter Nutzer
  • Beiträge: 9
Antw: Meta Tag für Robots; Bug oder nicht Bug?
« Antwort #1 am: 22. März 2012, 19:58:56 »
Es kommt ein bischen drauf an. Wenn der Parameter in den globalen Menü-Einstellungen drin steckt, also nicht im XML der entsprechenden Komponente definiert ist, ist das Verhalten falsch. Dann muss Joomla für den follow/nofollow im header sorgen. Den nofollow am Menülink muss es sowieso setzen.

Wenn das in der Komponenten XML ist, dann ist das eine Sache der Komponente.

Sinnvoll ist es meines erachtens nach aber nur als allgemeiner Parameter, also Komponenten unabhängig.

Joomla-Hilfe

  • Oberwetterfrosch (Mod)
  • Beiträge: 155
Antw: Meta Tag für Robots; Bug oder nicht Bug?
« Antwort #2 am: 22. März 2012, 20:05:17 »
Der Parameter steht in den Metadatenoptionen, und die haben AFAIK nichts mit der XML der Komponente zu tun. Im selben Abschnitt werden Meta Description und Meta Keywords gesetzt, und die werden ohne Aktion der Komponente ausgegeben.
Dietmar

Die Realität ist eine Halluzination, die durch akuten Alkoholmangel hervorgerufen wird.

Hackwar

  • Bestätigter Nutzer
  • Beiträge: 9
Antw: Meta Tag für Robots; Bug oder nicht Bug?
« Antwort #3 am: 22. März 2012, 20:09:03 »
Naja, mit JForm ist es ziemlich egal, welches Feld du meinst, denn ich kann ja auf jedes Feld zugreifen/da rein schreiben. Nichts desto trotz ist es eigentlich nur logisch, dass das Feld in den globalen Parametern und nicht in der Komponente definiert ist.

Joomla-Hilfe

  • Oberwetterfrosch (Mod)
  • Beiträge: 155
Antw: Meta Tag für Robots; Bug oder nicht Bug?
« Antwort #4 am: 22. März 2012, 20:16:15 »
Naja, mit JForm ist es ziemlich egal, welches Feld du meinst, denn ich kann ja auf jedes Feld zugreifen/da rein schreiben.
Klar, und eine Komponente kann auch jeden globalen Parameter überschreiben oder löschen, egal was der Admin reinschreibt/auswählt. Aber wenn sie das nicht macht, sollte sich Joomla konsistent verhalten und alle globalen Parameter so ausgeben, wie sie im Menüpunkt eingestellt sind, und nicht nur einige.
Dietmar

Die Realität ist eine Halluzination, die durch akuten Alkoholmangel hervorgerufen wird.